Image Image Image Image Image Image Image Image Image Image

Ubuntu Server | November 24, 2017

Scroll to top

Top

2 Comments

Configurazione MultiSid + Vlan tra Ubiquiti Unifi e Routerboard Mikrotik

Configurazione MultiSid + Vlan tra Ubiquiti Unifi e Routerboard Mikrotik

L’altro giorno mi è capitato di fare una config un po particolare, e visto che ci ho sbattuto per farla volevo condividerla con il mondo 🙂
In questo esempio vi mostrerò come configurare 3 interfacce con la propria sottorete ed il proprio dhcp-server utilizzando una antenna
Ubiquiti Unifi ed una RouterBoard Mikrotik 1000.
Queste reti sono due interfacce fisiche e due vlan, le fisiche saranno ether3 ed ether4 mentre le vlan sono 10 e 20.
La porta ether4 sarà configurata come trunk per l’Unifi e trasporterà due Vlan la 10 e la 20 mentre la ether3
sara configurata con la network di management senza tag così da poter raggiungere il software il computer dove
è installato il software per il controllo degli ap UniFI.

 

Fase 1 – Configurazione RouterBoard Mikrotik

 

/interface bridge
add l2mtu=1598 name=lan
add l2mtu=1594 name=vlan10
add l2mtu=1594 name=vlan20
 
/interface vlan
add interface=ether4 l2mtu=1594 name=vl-lan10-ether4 vlan-id=10
add interface=ether4 l2mtu=1594 name=vl-lan20-ether4 vlan-id=20
 
/ip dns
set allow-remote-requests=yes servers=8.8.4.4,208.67.220.220
/ip dns static
add address=192.168.9.100 name=unifi
 
/interface bridge port
add bridge=lan interface=ether3
add bridge=lan interface=ether4
add bridge=vlan10 interface=vl-lan10-ether4
add bridge=vlan20 interface=vl-lan20-ether4
 
/ip neighbor discovery
set vl-lan10-ether4 discover=no
set vl-lan20-ether4 discover=no
 
/ip pool
add name=dhcp_lan ranges=192.168.9.2-192.168.9.254
add name=dhcp_vlan10 ranges=192.168.10.2-192.168.10.254
add name=dhcp_vlan20 ranges=192.168.20.2-192.168.20.254
 
/ip dhcp-server
add address-pool=dhcp_lan disabled=no interface=lan name=dhcp_lan
add address-pool=dhcp_vlan10 disabled=no interface=vlan10 name=dhcp_vlan10
add address-pool=dhcp_vlan20 disabled=no interface=vlan20 name=dhcp_vlan20
 
/ip address
add address=192.168.9.1/24 interface=lan network=192.168.9.0
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
 
/ip dhcp-server network
add address=192.168.9.0/24 dhcp-option=unifi dns-server=192.168.9.1 gateway=\
192.168.9.1
add address=192.168.10.0/24 dhcp-option=unifi dns-server=192.168.10.1 gateway=\
192.168.10.1
add address=192.168.20.0/24 dhcp-option=unifi dns-server=192.168.20.1 gateway=\
192.168.20.1

 

 

Fase – Configurazione del controller Unifi:

Video di esempio dove mostra gli step di una prima configurazione del controller

 

Colleghiamoci con il PC dove è installato il software Ubiquiti sulla porta ether3 ed impostiamo sulla nostra interfaccia di rete l’ip 192.168.9.100/24 con gateway 192.168.9.1. Apriamo il browser all’indirizzo https://localhost:8443 ed eseguiamo il Wizard della prima configurazione, dopo aver terminato il wizard andiamo in Settings – Wlan Group ed aggiungiamo un ESSID WIFI-MGM senza vlan così farà parte della network 192.168.9.0/24 così riuscita a comunicare con il controller senza traffico taggato. Dopo aggiungeremo altri due ESSID WIFI-VLAN10 e WIFI-VLAN20 con le rispettive vlan 10 e 20, ed avranno le network 192.168.10.0/24 e 192.168.20.0/24, fatto questo se ci colleghiamo in Wifi ad ogni singolo ESSID avremo accesso a network diverse e sulla nostra Mikrotik possiamo fare quello che vogliamo ad ex. Hotspot sulla VLAN10 oppure regole di Banda o di accesso alle singole network.

Spero possa essere utile a molti 😀

Comments

  1. Mille grazie, per questo esempio di configurazione ha funzionato perfettamente.
    Soltanto se sono nella Vlan10 posso fare un ping nella Vlan20 e viceversa. Mi potresti dare una dritta per non consentire questo Routing?

    • Mi fa piacere quando le mie esperienze sono di aiuto 🙂
      Allora una volta fatto funzionare le vlan ti basta fare delle regoline firewall, eccoti un esempio:
      /ip firewall filter
      add chain=forward comment=”Inizio RegoleWifiEsterni” dst-address=192.168.1.186 src-address=192.168.50.0/24
      add chain=forward dst-address=192.168.1.1 src-address=192.168.50.0/24
      add action=drop chain=forward comment=”Fine RegoleWifiEsterni” dst-address=192.168.1.0/24 src-address=192.168.50.0/24

      In questo esempio i client della sottorete 50 posso andare su internet e raggiungere il server .186 ma non possono vedere il resto della rete.

      p.s ricordati che le regole vanno dall’alto verso il basso 😉

Submit a Comment

*

adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample