Image Image Image Image Image Image Image Image Image Image

Ubuntu Server | August 17, 2018

Scroll to top

Top

No Comments

Monitoraggio Devices Poe-out tramite una Mikrotik 750UP

Monitoraggio Devices Poe-out tramite una Mikrotik 750UP

La Mikrotik 750UP è l’evoluzione della storica 750 con l’aggiunta di caratteristiche molto interessanti. Oltre ad essere alimentabile via POE (occhio, passivo e quindi non 802.3af) ossia tramite alimentazione su cavo LAN(ether1), ha le porte dalle 2 alla 5 che sono delle porte POE-injector(POE-Out) ossia possono alimentare a loro volta 4 apparati POE  fino ad un massimo di assorbimento per porta di 1A. Proprio di questa ultima funzionalità andremo a parlare, e nel dettaglio implementeremo uno script che pingherà i devices alimentati sulle porte poe-out e se non rispondo a X ping verra tolta la corrente e rimessa per riavviarli.

Procediamo creando uno nuovo script sotto system -> script
che chiameremo PoeCheckPing

# Qui mettiamo l’ip del device da pingare

:local PingAddress 192.168.20.2

# Qui inseriamo i tentativi di ping prima di spegnere e riaccendere la porta

:local PingCount 5

# Qui specifichiamo quale porta vogliamo riavviare

:local PoEPort ether5

# Qui specifichiamo il tempo di spegnimento della porta prima di riaccenderla

:local PoETime 10

# Qui impostiamo la riaccensione della porta

:local PortState forced-on

# Qui mettiamo i parametri per l’invio dell’email avvisandoci del cambio di stato

 

:local EmailAddress francesco.gabriele@gmail.com
:local SMTPServer smtp.baleno.it
:local SMTPUser email@baleno.it
:local SMTPPassword b4l3n0
 
{
:if ([/ping $PingAddress count=$PingCount] = 0) do={
/interface ethernet set $PoEPort poe-out=off
delay $PoETime
/interface ethernet set $PoEPort poe-out=$PortState
 
/tool e-mail send to=$EmailAddress \
subject="La Porta $PoEPort è stata riavviata" server=$SMTPServer \
user=$SMTPUser password=$SMTPPassword
}
}

 

Submit a Comment

*

adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample