Image Image Image Image Image Image Image Image Image Image

Ubuntu Server | November 20, 2019

Scroll to top

Top

2 Comments

Configurazione VLAN tramite Bridging e tramite chip switch interno su Mikrotik 6.xx RB750/RB951/RB2011

Configurazione VLAN tramite Bridging e tramite chip switch interno su Mikrotik 6.xx RB750/RB951/RB2011

Oggi cercherò di spiegare come utilizzare le VLAN su Mikrotik, le informazioni in rete sono abbastanza confuse ed è per questo che ho deciso di scrivere un articolo.

Prima di tutto con Mikrotik esistono due modalità di configurazione delle VLAN:
1)VLAN tramite Bridging
2)VLAN tramite Chip Switch

Il primo metodo utilizza il sistema operativo per tutte le funzioni di tagging, mentre il secondo metodo utilizza un chipset interno per la gestione dello switch.

Nella foto qui sotto si trova una semplice rappresentazione logica del funzionamento interno della Mikrotik.

Mikrotik-Internal

La differenza sostanziale tra i due metodi oltre alla semplicità di configurazione tra il primo e il secondo è sopratutto la differenza d’impegno di risorse hardware sopratutto in termini di cpu.

1) Iniziamo con la prima modalità “VLAN Bridging” però prima di mostrarvi un esempio di configurazione, volevo farvi vedere a livello hardware come lavorano i componenti:

Mikrotik-Vlan-Brdiging-Schema

Non c’è niente di sbagliato in questa configurazione e ci permetti di avere molta flessibilità, ma quando hai solo bisogno di switching Layer 2 questo genera un sacco di inutili pressioni sulla CPU
che già di suo viene applicata per tutte le altre funzioni di routing.

Di seguito un esempio di Configurazione VLAN Bridging:

Configuriamo la ether1 in Trunk

/interface vlan add name=vlan-10 vlan-id=10 interface=ether1 disabled=no
/interface vlan add name=vlan-20 vlan-id=20 interface=ether1 disabled=no

Creiamo i bridge per effettuare il forward dei pacchetti provenineti dalle porte in access verso la ether1 che è in trunk

/interface bridge add name=br-vlan10 disabled=no
/interface bridge add name=br-vlan20 disabled=no

Associamo i bridge con le rispettive interfacce:

/interface bridge port add interface="vlan-10" bridge="br-vlan10" disabled=no
/interface bridge port add interface="ether2" bridge="br-vlan10" disabled=no
/interface bridge port add interface="vlan-20" bridge="br-vlan20" disabled=no
/interface bridge port add interface="ether3" bridge="br-vlan20" disabled=no

Ed ecco alcuni screenshot:

InterfacesVlan Bridge2 Bridge1

 

Riepilogando in questo esempio abbiamo messo la ether1 in Trunk ed abbiamo configurato al ether2 e la ether3 in access sulla vlan10 e 20.

 

2) Ora invece vediamo la seconda modalità “VLAN tramite Chip Switch” ed anche in questo caso vi mostro come si comportano i componenti hardware:

mikrotik-vlan-taggin-chip

Nella foto sopra l’interfaccia ether01 è in trunk mentre le altre due sono configurate in access, e come potete vedere il traffico passa dal Chip Switch e non dalla cpu. In questo modo l’hardware lavora in maniera più efficiente e di conseguenza abbiamo un Throughput Maggiore.

Non tutti i chipset presenti sulle Routerboard Mikrotik supportano il chip switch, di seguito una tabella dove mostra quelli supportati e le features:

Chipset

In questo esempio useremo una Mikrotik 750GL che monta il chipset Atheros8327 di seguito lo screenshot del chipset:

Mikrotik750GL-Switch-Vlan1

Per abilitare le funzioni switch dobbiamo prima definire una master-port ed in questo caso useremo al ether1:

/interface ethernet
set [ find default-name=ether2 ] master-port=ether1
set [ find default-name=ether3 ] master-port=ether1
set [ find default-name=ether4 ] master-port=ether1
set [ find default-name=ether5 ] master-port=ether1

 

MasterPort

Vediamo come si presentano di default le porte:

Mikrotik750GL-Switch-Vlan2

Ora impostiamo la porta ether2 in trunk e le porte 3-4-5 in access:

Chipset-config

Mikrotik750GL-Switch-Vlan3

Ora configuriamo le VLAN associandole alle porte appena configurate:

Mikrotik750GL-Switch-Vlan4

 

In questo modo abbiamo completato la configurazione e quindi se ci taghiamo con le giuste VLAN ex. 31 o 810 veniamo instradati sulle relative sotto reti.

Se per qualche motivo abbiamo la necessità di configurare un ip di managment ad ex. sulla VLAN 31 o configurare un dhcp-server, dobbiamo settare la vlan sia nella sezione switch che nella sezione interfaces -> vlan e nella sezione switch insieme all’interfaccia “ether2” va messo lo switch1-cpu come nel printscreen che segue:

 

Chipset-config-Trunk-Access-With-Dhcp

Questo è tutto! Spero che le informazioni siano utili a molti e che vi diano una chiara comprensione di come funzionano le VLAN con Mikrotik sulle serie RB750/RB951/RB2011.

Frank

 

 

Comments

  1. Bellissimo e chiaro articolo. Complimenti e grazie per la condivisione!!!

Submit a Comment

*

adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample