Image Image Image Image Image Image Image Image Image Image

Ubuntu Server | November 27, 2022

Scroll to top

Top

No Comments

DD-WRT AP’s Multi-SSID (VLAN) with Mikrotik RB750/RB951/RB2011

DD-WRT AP’s Multi-SSID (VLAN) with Mikrotik RB750/RB951/RB2011

DD-WRT è un firmware Open Source basato su Linux,supporta parecchi router wireless, qui potete trovate una lista (www.dd-wrt.com/site/support/router-database).
E’ molto potente e robusto ed aggiunge parecchie funzionalità in confronto al firmware, in più ha un interfaccia web abbastanza user friendly.
Il firmware si presta ai più svariati utilizzi, sia in ambito domestico che aziendale,i o lo uso da parecchio tempo e lo installo su tutti i router che mi capitano a tiro e lo supportano sopratutto con i modelli TP-LINK.
Tra le funzioni più utilizzate troviamo la possibilità di impostare il router in modalità client, WDS repeater o client bridged ed anche lui supporta la modalità MultiSSID con relativa gestione delle VLAN.

Infatti oggi andremo a parlare proprio di questa funzionalità, come al solito il routing di base lo facciamo gestire ad una mikrotik della serie RB750/RB951/RB2011, ed ecco la solita config:

/interface bridge
add l2mtu=1516 name=brdige_vlan10
add l2mtu=1520 name=bridge_lan
add l2mtu=1516 name=bridge_vlan20
/interface ethernet
set [ find default-name=ether2 ] master-port=ether1
set [ find default-name=ether3 ] master-port=ether1
set [ find default-name=ether4 ] master-port=ether1
/interface vlan
add interface=ether5 l2mtu=1516 name=vlan10 vlan-id=10
add interface=ether5 l2mtu=1516 name=vlan20 vlan-id=20
/ip pool
add name=dhcp_vlan10 ranges=192.168.10.2-192.168.10.254
add name=dhcp_vlan20 ranges=192.168.20.2-192.168.20.254
/ip dhcp-server
add address-pool=dhcp_vlan10 disabled=no interface=brdige_vlan10 name=dhcp_vlan10
add address-pool=dhcp_vlan20 disabled=no interface=bridge_vlan20 name=dhcp_vlan20
/interface bridge port
add bridge=brdige_vlan10 interface=vlan10
add bridge=bridge_vlan20 interface=vlan20
add bridge=bridge_lan interface=ether5
add bridge=bridge_lan interface=ether1
/ip address
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1 use-peer-ntp=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge_lan
/ip upnp
set allow-disable-external-interface=no
/system clock
set time-zone-name=Europe/Rome
/system identity
set name=MikroTik-DD-WRT
/system ntp client
set enabled=yes primary-ntp=91.189.89.199 secondary-ntp=91.189.94.4

Ora procediamo con la config lato DD-WRT, di seguito gli step:

1) Disabilitazione Connessione Internet + Configurazione Ip Managment
2) Disabilitazione Dhcp server
3) Settaggio modalità operativa da Gateway a Router
4) Configurazione SID di Managment
5) Configurazione Virtual AP
6) Su ogni Virtual AP impostiamo il “Network Configuration” in “Unbridged”
7) Settiamo le VLAN 10 e 20 in questo caso sulla eth1
8) Creiamo due bridge (bridge10 e brdige20)
9) Aggiungiamo al bridge10 la eth1.10 e la ath0.1
10) Aggiungiamo al bridge20 la eth1.20 e la ath0.2

Per aiutarci diamo un occhiata ai print screen che ho fatto qui sotto, ora se è tutto corretto
se ci colleghiamo ai singoli SSID ci dovrebbe assegnare un ip diverso in base alle vlan.

1 2 3 4 5 6 7 8

Submit a Comment

*

adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample