Image Image Image Image Image Image Image Image Image Image

Ubuntu Server | August 3, 2020

Scroll to top

Top

No Comments

Dynamic DNS Update Script for NO-IP behind NAT on Mikrotik Router

Dynamic DNS Update Script for NO-IP behind NAT on Mikrotik Router
Francesco Gabriele

Basandomi sul mio precedente script  p ho effettuate alcune modifiche prendendo esempio da un esempio di script che utilizza DynDNS sempre dietro nat  p

Eccolo:

# No-IP automatic Dynamic DNS update Behind Nat By Frank

#————— Change Values in this section to match your setup ——————

# No-IP User account info
:local noipuser “noip_user”
:local noippass “noip_password”

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost “noip_domain”

#————————————————————————————

:global previousIP

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address=”checkip.dyndns.org” src-path=”/” dst-path=”/nat.checkip.html”
:local result [/file get nat.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result “: ” -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result “</body>” -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info “UpdateNatNoipDNS: currentIP = $currentIP”

# The update URL. Note the “\3F” is hex for question mark (?). Required since ? is a special character in commands.
:local url “http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP”
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info “No-IP: Sending update for $host”
/tool fetch url=($url . “&hostname=$host”) user=$noipuser password=$noippass mode=http dst-path=(“no-ip_ddns_update-” . $host . “.txt”)
:log info “No-IP: Host $host updated on No-IP with IP $currentIP”
}

Di seguito la solita schedulazione:

/system scheduler

add disabled=no interval=5m name=no-ip_ddns_update on-event=no-ip_ddns_update policy=ftp,read,write,test,winbox,api start-date=apr/21/2013 start-time=18:46:4

 

Submit a Comment

*

adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample