Image Image Image Image Image Image Image Image Image Image

Ubuntu Server | November 27, 2022

Scroll to top

Top

4 Comments

TP-LINK AP’s Multi-SSID (VLAN) with Mikrotik RB750/RB951/RB2011

TP-LINK AP’s Multi-SSID (VLAN) with Mikrotik RB750/RB951/RB2011

Vi sono alcuni modelli di Access Point TP-LINK come il TL-WA701ND, TL-WA801ND, TL-WA901ND, che hanno una funzione chiamata “Multi-SSID”.
Questa funzione permette di configurare fino a 4 SSID con nomi e VLAN ID differenti, questa funzionalita permette di ottenere un livello di accesso diverso a secondo del SSID configurato ed in questo ci verrà in aiuto la nostra cara Mikrotik gestendo sotto tutto il routing.

Come nel precedente articolo http://www.ubuntuserver.it/configurazione-multisid-vlan-tra-ubiquiti-unifi-e-routerboard-mikrotik/  vi mostro di seguito la config della routerboard:

/interface bridge
add l2mtu=1516 name=brdige_vlan10
add l2mtu=1520 name=bridge_lan
add l2mtu=1516 name=bridge_vlan20
/interface ethernet
set [ find default-name=ether2 ] master-port=ether1
set [ find default-name=ether3 ] master-port=ether1
set [ find default-name=ether4 ] master-port=ether1
/interface vlan
add interface=ether5 l2mtu=1516 name=vlan10 vlan-id=10
add interface=ether5 l2mtu=1516 name=vlan20 vlan-id=20
/ip pool
add name=dhcp_vlan10 ranges=192.168.10.2-192.168.10.254
add name=dhcp_vlan20 ranges=192.168.20.2-192.168.20.254
/ip dhcp-server
add address-pool=dhcp_vlan10 disabled=no interface=brdige_vlan10 name=dhcp_vlan10
add address-pool=dhcp_vlan20 disabled=no interface=bridge_vlan20 name=dhcp_vlan20
/interface bridge port
add bridge=brdige_vlan10 interface=vlan10
add bridge=bridge_vlan20 interface=vlan20
add bridge=bridge_lan interface=ether5
add bridge=bridge_lan interface=ether1
/ip address
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1 use-peer-ntp=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge_lan
/ip upnp
set allow-disable-external-interface=no
/system clock
set time-zone-name=Europe/Rome
/system identity
set name=MikroTik-Tplink
/system ntp client
set enabled=yes primary-ntp=91.189.89.199 secondary-ntp=91.189.94.4

Questa config a differenza di quella del vecchio post ha la ether1 configurata in dhcp client cosi da essere usata come WAN infatti ho messo anche una regola di masquerade.

Ora invece vediamo la config lato TP-LINK partendo dal Wizard iniziale:

2 3 4 5 6 7 8

Una volta terminato il wizard se ci colleghiamo ai vari SSID dovremmo ricevere un ip differente in base alla VLAN.

Comments

  1. Cip

    It does not work for me.
    I actually need several APs with 2 SSID for each.
    When I enable multiple SSID and VLAN, it keeps rebooting.

    I have for of them, at least 2 do this, they are new, so I am sure there is something more.

    I have created vlans before on MTK.

    I will try with openWRT..hope it works.

  2. kzoltaan

    The dhcp is not working on vlan. Can u help me?

Submit a Comment

*

adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 sample adidas yeezy boost 650 v1 adidas yeezy 650 boost adidas yeezy boost 650 adidas yeezy 650 boost colorways adidas yeezy 650 350 2 0 boost yeezy boost 650 adidas yeezy boost 650 supreme x nike air uptempo release info adidas yeezy boost 650 v1 sample detailed look adidas yeezy boost 650 v1 sample